Access to travel authorization and reimbursement from FTS is currently unavailable.
Incident Report for SJSU System Status
Resolved
Access to travel authorization and reimbursement from FTS has been restored.
Posted Mar 03, 2015 - 06:28 PST
Investigating
The travel approval structures in FTS are currently unavailable. We anticipate that they will be unavailable through February 27. We apologize in advance for any inconvenience and will post an update February 27 at 9:00 am.
Posted Feb 26, 2015 - 10:19 PST
This incident affected: Applications (Financial Transaction Services (FTS)).