Campus on-line directory unavailable
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 9 months ago. Sep 24, 2018 - 13:35 PDT
Investigating
We are currently investigating the issue.
Posted 9 months ago. Sep 24, 2018 - 12:13 PDT
This incident affected: SJSU Online Directory.