Canvas is running slowly.
Incident Report for SJSU System
Resolved
Canvas is running a normal speed.
Posted about 1 month ago. Nov 15, 2017 - 13:18 PST
Monitoring
Canvas is running slowly. The issue appears to be the result of slow connectivity from the regional Internet provider.
Posted about 1 month ago. Nov 15, 2017 - 12:56 PST
This incident affected: Canvas Learning Mgt System.