HCM non-production is currently down.
Incident Report for SJSU System Status
Resolved
This issue has been resolved at the Chancellor's Office.
Posted May 19, 2016 - 12:16 PDT
Investigating
We have reports that the HCM non-production system is down.
Posted May 19, 2016 - 11:16 PDT
This incident affected: Others (Campus Notifications).