VPN services are not available
Incident Report for SJSU System
Resolved
VPN is now available.
Posted 18 days ago. Jul 10, 2017 - 09:15 PDT
Investigating
VPN Services are not currently working.
Posted 21 days ago. Jul 06, 2017 - 13:39 PDT
This incident affected: Campus Network.