Google has identified why some people are experiencing issues with email address "type-ahead" in Gmail.
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Mar 03, 2015 - 08:58 PST
Identified
On Feb. 20th, 2015 an issue in Gmail temporarily corrupted a subset of users' contacts. While the original issue was fixed on the same day, those users who received messages from the previously corrupt contacts have since been reporting unexpected behavior with the Gmail auto-complete feature. After typing an affected contact's name into the Gmail compose box, you'll see the contact's name appear at the bottom of the auto-complete list when the contact should appear at the top of the list.

We're unable to provide a feasible workaround at this time, but rest assured our Gmail engineers are diligently working to fix this issue. The root cause of the issue was identified and mitigated. The product team is working now on restoring the order of suggestions the auto-complete feature provides.

For updates users are encouraged to visit the Google Apps Known Issues web page at https://support.google.com/a/answer/6166309?rd=1
Posted Feb 25, 2015 - 13:52 PST
This incident affected: Applications (SJSU Google Workspace).