Internet access is not available from on campus.
Incident Report for SJSU System
Resolved
The issue has been resolved and Internet Services have been restored to campus.
Posted 11 months ago. Jun 07, 2017 - 12:43 PDT
Investigating
Internet access is not available on campus. Email is available off campus.
Posted 11 months ago. Jun 07, 2017 - 12:39 PDT
This incident affected: Campus Network.