Finesse Call Center Software Not Authenticating
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 15, 2018 - 11:18 PDT
Investigating
The software used by call centers on campus (Finesse) is not authenticating new logins.

For those calling the campus, please note that you may be on hold for longer than usual as representatives may not be able to get to your call as quickly. Voicemail is still functional.

For those are signed into Finesse, the campus advises that you remain signed in, as if you sign out of the software, you may be unable to sign back in to resume answering calls.

Communication Services are investigating this issue and hope to have a solution soon.
Posted about 1 month ago. Jun 15, 2018 - 09:21 PDT
This incident affected: Finesse (Call Center).