Finesse Call Center
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 28, 2018 - 11:13 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. Jun 28, 2018 - 07:56 PDT
This incident affected: Finesse (Call Center).