Planned Turnitin Maintenance
Scheduled for Jul 10, 08:00 - 16:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted 8 days ago. Jun 13, 2018 - 11:04 PDT
Scheduled
Turnitin will be unavailable during a scheduled maintenance period on Tuesday, July 10th, 2018 from 8:00 a.m. to 4:00 p.m.
Posted 8 days ago. Jun 13, 2018 - 10:48 PDT
This scheduled maintenance affects: Canvas Learning Mgt System.