Finesse Server is down

Incident Report for SJSU System Status

Resolved

This incident has been resolved.
Posted Mar 08, 2023 - 10:18 PST

Update

To contact the Service Desk, Please reach out to us using Live Chat or email at itservicedesk@sjsu.edu.
Posted Mar 08, 2023 - 08:44 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 08, 2023 - 08:18 PST
This incident affected: Infrastructure (Finesse (Call Center)).