Amazon Web Services is continuing to work toward a full resolution of their residual network connectivity issues. Updated status information is available from the AWS Health Dashboard >>> https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:18 PDT
Identified
AWS is aware of the issues and is currently working to resolve the outage.
Posted Oct 20, 2025 - 12:12 PDT
This incident affected: Center for Faculty Excellence and Teaching Innovation (CFETI) Apps (Canvas Learning Mgt System), Others (Spartan Connect), Infrastructure (WEPA Printing System), and Applications (Zoom, QLess).