Google Drive, Sheets and Docs - Global Technical Issues

Incident Report for SJSU System Status

Resolved

Issues with Google Workspace products are now mitigated.
Posted Nov 12, 2025 - 17:33 PST

Investigating

Google is experiencing a global issue with Google Drive, Google Sheets, Google Docs. You may experience intermittent issues with these three products. We will provide updates as soon as possible
Posted Nov 12, 2025 - 11:46 PST
This incident affected: Applications (SJSU Google Workspace).