We will be undergoing scheduled maintenance during this time.
Posted Apr 24, 2025 - 16:00 PDT
Scheduled
The OnBase content management system will be offline for maintenance from 5pm on Friday, May 2 to 10am on Saturday, May 3. During this time, all OnBase functionality will be unavailable, including digital forms for Admissions and the Registrar's Office.
Posted Apr 24, 2025 - 15:59 PDT
This scheduled maintenance affects: Applications (OnBase (Electronic Documents, Forms & Workflow Service)).