Canvas is currently unavailable.
Incident Report for SJSU System Status
Resolved
The system is now functioning.
Posted May 16, 2017 - 13:28 PDT
Investigating
Canvas is currently unavailable.
Posted May 16, 2017 - 13:20 PDT
This incident affected: SJSU eCampus Applications (Canvas Learning Mgt System).