Duo Unavailable

Incident Report for SJSU System Status

Resolved

This incident has been resolved.
Posted Jan 09, 2025 - 15:35 PST

Investigating

We are currently investigating this issue.
Posted Jan 09, 2025 - 15:08 PST
This incident affected: All Campus Systems.