SJSU Website (www.sjsu.edu).
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 16:00 PST
Investigating
We are currently investigating this issue.
Posted Nov 06, 2023 - 09:52 PST
This incident affected: All Campus Systems.