OS upgrade -

Scheduled for Jan 5, 08:00 - 17:00 PST

Update

Publishing unavailable for January 5-6, 2026.
Posted Dec 23, 2025 - 13:44 PST

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Dec 23, 2025 - 12:40 PST
This scheduled maintenance affects: Applications (OU Campus (Website Content Mgt System)).