Emergency blue light phones are not in service
Incident Report for SJSU System
Resolved
The power issue has been resolved and the emergency blue light phones are now functional.
Posted 5 months ago. Jun 06, 2017 - 19:35 PDT
Investigating
Due to electrical issues, the emergency blue light phones are not in service. For emergency assistance, please dial 911.
Posted 5 months ago. Jun 06, 2017 - 17:12 PDT
This incident affected: Voice and Video Communication Systems.