MySJSU is unavailable.
Incident Report for SJSU System
Resolved
The issue has been resolved and MySJSU is now available.
Posted about 1 month ago. Nov 13, 2017 - 18:56 PST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Nov 13, 2017 - 18:40 PST
This incident affected: MySJSU.