SJSU Password Self-Reset is currently unavailable.
Incident Report for SJSU System
Resolved
Password self-reset is now available.
Posted 5 months ago. Dec 12, 2017 - 08:36 PST
Investigating
Password self-reset is currently unavailable. We are working to resolve the issue.
Posted 5 months ago. Dec 12, 2017 - 08:15 PST
This incident affected: MySJSU.