Finesse (Call Center)
Incident Report for SJSU System
Resolved
Finesse Login for Call Centers is active.
Posted 12 months ago. Mar 26, 2018 - 13:07 PDT
Update
Finess Login is unavailable.
Posted 12 months ago. Mar 26, 2018 - 08:44 PDT
Update
We are currently experiencing an issue with Finesse log-in.
Posted 12 months ago. Mar 26, 2018 - 08:32 PDT
Identified
We are currently experiencing an issue with Finesse log-in. This is not impacting agents that are currently logged in. The issue is only when currently logged off agents are trying to log into Finesse.
Posted 12 months ago. Mar 23, 2018 - 12:28 PDT
This incident affected: Finesse (Call Center).