SJSU Web Pages
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 11, 2018 - 18:35 PDT
Investigating
We are experiencing issues that are affecting the appearance of some of our web pages. Please contact the Service Desk if you need assistance navigating the website.
Contact us at (408)924-1530
Posted 8 days ago. Jul 11, 2018 - 10:17 PDT