iSupport is currently unavailable.
Incident Report for SJSU System
Resolved
The issue is resolved.
Posted 7 months ago. May 01, 2017 - 20:32 PDT
Investigating
The iSupport ticketing system is currently unavailable.
Posted 7 months ago. May 01, 2017 - 09:40 PDT
This incident affected: iSupport Help Desk Ticketing System.