iSupport is down
Incident Report for SJSU System
Resolved
The issues has been resolved.
Posted 7 months ago. Mar 03, 2017 - 16:33 PST
Investigating
The iSupport ticketing system is down.
Posted 7 months ago. Mar 03, 2017 - 12:48 PST
This incident affected: iSupport Help Desk Ticketing System.