IPM is currently unavailable.
Incident Report for SJSU System Status
Resolved
The issue with IPM has been resolved.
Posted Jun 27, 2016 - 11:57 PDT
Investigating
We are working to resolve the issue with the IPM system.
Posted Jun 27, 2016 - 11:26 PDT
This incident affected: Others (Campus Notifications).