Clark Lab 102 is currently unavailable
Incident Report for SJSU System
Resolved
The network issue has been resolved.
Posted 10 months ago. Feb 02, 2017 - 17:49 PST
Investigating
The Clark 102 Computer lab is currently unavailable due to a network issue.
Posted 10 months ago. Feb 02, 2017 - 15:56 PST
This incident affected: Campus Network.