College of Business Labs are currently unavailable.
Incident Report for SJSU System Status
Resolved
The issue with the server has been resolved and COB Labs are now functional and available.
Posted Aug 20, 2015 - 12:48 PDT
Investigating
COB Labs are currently unavailable. We are working with the local technicians to resolve the issue.
Posted Aug 20, 2015 - 11:10 PDT