Intermittent Issue with International Calling
Incident Report for SJSU System Status
Resolved
This issue has been resolved.
Posted Jan 17, 2017 - 09:58 PST
Investigating
We are experiencing intermittent issues with International calling.
Posted Jan 13, 2017 - 15:13 PST
This incident affected: Infrastructure (Voice and Video Communication Systems).