MySJSU / PeopleSoft Campus Solutions Has Reduced Performance
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 26, 2018 - 16:07 PST
Update
MySJSU PeopleSoft login for some APPLICANTS is intermittent.
Posted 9 months ago. Jan 26, 2018 - 12:43 PST
Investigating
MySJSU PeopleSoft login for applicants is intermittent.
Posted 9 months ago. Jan 26, 2018 - 10:48 PST
This incident affected: MySJSU.