South Campus network outage
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 10 days ago. May 11, 2018 - 06:50 PDT
Investigating
We are currently investigating.
Posted 10 days ago. May 11, 2018 - 06:43 PDT
This incident affected: Campus Network.