ISupport is down
Incident Report for SJSU System
Resolved
The issue has been resolved. iSupport is available for use.
Posted about 1 month ago. Nov 16, 2017 - 11:46 PST
Investigating
The iSupport ticketing system is currently down.
Posted about 1 month ago. Nov 16, 2017 - 11:38 PST
This incident affected: iSupport Help Desk Ticketing System.