Adobe Downloads and Updates are not availble
Incident Report for SJSU System Status
Resolved
Adobe Licenses are now available for download.
Posted Aug 30, 2016 - 13:19 PDT
Investigating
The Adobe download/update for this year's license is currently not available. The Chancellor's Office is working to resolve the issue.
Posted Aug 30, 2016 - 09:25 PDT
This incident affected: Others (Campus Notifications).