iSupport intermittent connection
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 25, 2018 - 09:55 PDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Oct 25, 2018 - 09:14 PDT
This incident affected: iSupport Help Desk Ticketing System.