Finesse is Down
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 14 days ago. Aug 03, 2018 - 07:58 PDT
Update
Call centers are down; For assistance, please email the Service Desk at itservicedesk@sjsu.edu.
Posted 14 days ago. Aug 03, 2018 - 07:56 PDT
Investigating
We are currently investigating this issue.
Posted 14 days ago. Aug 03, 2018 - 07:30 PDT
This incident affected: Finesse (Call Center).