Password Self-Reset option 2 is unavailable
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 10:52 PST
Investigating
Please contact the Service Desk at (408)924-1530 or set up a Zoom meeting via the Service Desk webpage if you are unable to reset your password using option one.
Posted Jan 04, 2021 - 10:06 PST