Google issues
Incident Report for SJSU System Status
Resolved
Goggle has resolved the issue.
Posted Oct 27, 2014 - 14:19 PDT
Update
Google is still working to resolve any outstanding issues.
Posted Oct 27, 2014 - 11:53 PDT
Update
Google is still working to fully resolve the issue. Services are available but may be slow or intermittently available. We will provide another update at 11:30 AM.
Posted Oct 27, 2014 - 10:51 PDT
Investigating
Google is reporting issues with Drives, Docs, Sheets and Slides. We will provide more information as it becomes available.
Posted Oct 27, 2014 - 09:36 PDT
This incident affected: Applications (SJSU Google Workspace).