Network and telephones are down in the Administration Building
Incident Report for SJSU System
Resolved
This issue has been resolved.
Posted 26 days ago. Oct 23, 2017 - 11:04 PDT
Investigating
We are investigating the issue with networking and telephones not being available in the Administrative building.
Posted 26 days ago. Oct 23, 2017 - 08:43 PDT
This incident affected: Voice and Video Communication Systems and Campus Network.