Network is unavailable at South Campus
Incident Report for SJSU System
Resolved
South Campus network is back online.
Posted 3 months ago. Jul 12, 2017 - 07:45 PDT
Investigating
The network is currently down at South Campus.
Posted 3 months ago. Jul 12, 2017 - 07:39 PDT
This incident affected: Campus Network.