Library is inaccessible from campus
Incident Report for SJSU System Status
Resolved
The issue has been resolved. On campus users now have access to the Library's sites.
Posted Mar 25, 2015 - 14:20 PDT
Investigating
We are investigating the issue with accessing library sites from campus.
Posted Mar 25, 2015 - 12:43 PDT
This incident affected: Others (Library Administrative System).