iSupport Ticketing system is currently down.
Incident Report for SJSU System
Resolved
This issue has been resolved and the service is restored.
Posted about 2 months ago. Jun 01, 2017 - 14:14 PDT
Investigating
The iSupport ticketing system is currently down.
Posted about 2 months ago. Jun 01, 2017 - 13:50 PDT
This incident affected: iSupport Help Desk Ticketing System.