Finesse is down.
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 08, 2018 - 12:38 PDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Sep 07, 2018 - 09:33 PDT
This incident affected: Finesse (Call Center).