MySJSU @ Work
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 5 months ago. Aug 02, 2018 - 11:53 PDT
Investigating
Time and Labor page error for student employees.
Posted 5 months ago. Aug 01, 2018 - 09:44 PDT
This incident affected: SJSU @ Work.