Intermittent access to email
Incident Report for SJSU System
Resolved
The issue has been resolved and access is available.
Posted 5 months ago. Jul 21, 2017 - 08:43 PDT
Investigating
We are investing reports of intermittent email access.
Posted 5 months ago. Jul 21, 2017 - 07:52 PDT
This incident affected: SJSU Google Apps.