SJSU Online Directory is down.
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 19 days ago. Feb 02, 2018 - 09:33 PST
Identified
SJSU Online Directory search returns internal error message.
Posted 19 days ago. Feb 02, 2018 - 08:20 PST