HCM is currently unavailable.
Incident Report for SJSU System Status
Resolved
The issue has been resolved.
Posted May 15, 2015 - 16:25 PDT
Update
We believe that the issue has been resolved and we are monitoring the situation.
Posted May 15, 2015 - 11:01 PDT
Monitoring
The Human Resources and Student Affairs pages are not accessible.
Posted May 15, 2015 - 11:01 PDT