Campus email is incompatible with the Firefox version 37 browser.
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Apr 20, 2015 - 10:53 PDT
Identified
Campus email is incompatible with the Firefox version 37 browser. Please use Chrome, Internet Explorer or Safari to access your mail.
Posted Apr 13, 2015 - 09:54 PDT
This incident affected: Applications (SJSU Google Workspace).