OnBase is running slowly.
Incident Report for SJSU System
Resolved
The issue has been resolved
Posted 3 months ago. Mar 09, 2017 - 13:40 PST
Investigating
The OnBase system is running slowly. We are working to resolve the issue.
Posted 3 months ago. Mar 08, 2017 - 16:18 PST
This incident affected: OU Campus (Website Content Mgt System).