Center for Child Development network is down
Incident Report for SJSU System
Resolved
The issue has been resolved.
Posted 4 months ago. Mar 29, 2017 - 06:45 PDT
Investigating
The network is down for the Center for Child Development.
Posted 4 months ago. Mar 28, 2017 - 12:06 PDT
This incident affected: Campus Network.