Supporting documents feature for FTS and eInvoice are unavailable.
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Jan 21, 2015 - 13:34 PST
Identified
FTS supporting documents are now available to view. We are still getting occasional error; however, if you re-try the link, it works.
Posted Jan 05, 2015 - 14:24 PST
Investigating
FTS continues to be available for review and entry.
Posted Dec 17, 2014 - 13:10 PST
This incident affected: Applications (Financial Transaction Services (FTS)).